eclipse使用subclipse报错failed to load javahl library

  • 内容
  • 评论
  • 相关

在Eclipse中安装svn的插件,出现如下提示

主要原因是找不到JAVAHL

解决方案全部步骤整理如下:

1、安装subclipse,这是出这个错误前提就不用说了,可忽略

2、安装Subversion(系统应该自带,在终端使用svn --version查看一下试试)

http://www.collab.net/downloads/subversion

需要注册登陆,一堆必填项神烦啊,选择“Community Binaries”后下个最新版

3、安装macports

http://www.macports.org/install.php

吐槽下,安装虽然显示不到1分钟,但不知道为毛神慢,我等接近半小时才完成

安装完成macports后,执行命令:

sudo port -v selfupdate 更新下

4、安装xcode和command line tools(如已安装请忽略)

xcode不用说了,clt这么安装:

打开Xcode–》偏好设置–》download–》install command line tools

也可以打开终端,输入命令:xcode-select --install 按提示安装

5、安装javaHL

控制台执行命令:

sudo port install subversion-javahlbindings +no_bdb +universal

如果执行后出现

Error: Port subversion-javahlbindings not found错误,参考第三条进行更新,之后再次运行javaHL安装命令,就可以顺利执行了。

以上步骤完成之后,即可重新启动eclipse,此时subclipse即可使用了。

补充:

①macports应该是可以用HomeBrew替换,不过我没有尝试,如果是安装的HomeBrew这时运行的命令是:

brew install --universal --java subversion

②这里是JavaHL FAQ:

http://subclipse.tigris.org/wiki/JavaHL 安装命令就在这里有说明

 

评论

0条评论

发表评论

电子邮件地址不会被公开。 必填项已用*标注